1. Этот сайт использует файлы cookie. Продолжая пользоваться данным сайтом, Вы соглашаетесь на использование нами Ваших файлов cookie. Узнать больше.

Странности со скоростью в локальной сети

Тема в разделе "Компьютеры", создана пользователем DirectX, 25.06.07.

  1. DirectX

    DirectX Активный участник

    1.873
    0
    Значит имеется такая ситуация. Есть локальная сеть, в ней сервер на SUSE Linux Enterprise Server 10 и на нем поднята Samba 3. Имеются различные расшаренные папки. Сегодня понадобилось скачать на этот сервер несколько сот гигабайт и тут выяснилась одна любопытная деталь: при запуске копирования процесс шел очень медленно: около 200-400 килобайт в секунду! Самое интересное, что когда копирование (в Total Commander) отправлялось в фоновую задачу и ставилось копирование соседнего большого файла туда же, скорость каждого из двух потоков возрастала до 5000 килобайт в секунду, что в принципе уже ближе к норме. Стоило отменить одно из копирований, опять те же 200 килобайт :( Увеличение числа потоков свыше двух к росту суммарной скорости не приводило, но и не мешало. Что это за фигня может быть? В чем может быть загвоздка с настройками?
     
  2. qwertEHOK

    qwertEHOK Активный участник

    2.391
    1
    а если с линукса копировать на компы?
    а с компа на комп?
    а если на х*р убрать самбу?

    попробуй.
     
  3. Гость

    Гость Гость


    тогда скорость гарантировано станет равной нулю :)
    вне зависимости от числа потоков :)
     
  4. DirectX

    DirectX Активный участник

    1.873
    0
    В общем, продолжение истории. Может кому пригодится. Что было с первым компьютером пока не выяснял. Сегодня стал копировать слитую информацию на другом компьютере на подключенный SATA-диск. И на этот раз была примерно та же история - жуткие тормоза при копировании, а график скорости сетевого подключения представлял из себя расческу с максимумом в 20% пропускной способности, что я даже загрустил. Увеличение числа потоков правда скорость не увеличило. Потом в диспетчере задач перешел на вкладку загрузки процессора и заметил интересную вещь - этот график представлял собой полностью обратную картину - 100% загрузка с такими же провалами до 80%.

    Тут я понял, где собака порылась - посмотрел в оборудовании свойства дискового контроллера - и точно, оказалось, что диск работает в режиме PIO и даже простое копирование идет со скоростью 2 мегабайта в секунду. Выяснилось, что поскольку SATA-диск к этому компьютеру подключался первый раз, то нормальные драйверы для дискового контроллера не стояли :) Скачал с интернета, поставил - и тут же скорость копирования с диска на диск возросла в 20 раз, а загрузка процессора упала. И сеть заработала на уровне ровных 80% загрузки. Выключил QoS и стало практически 100.

    Таким образом, частично вопрос решился. Надо будет только выяснить, может на первом компьютере тоже подобная история была :)
     
  5. Alexs

    Alexs Активный участник

    9.156
    5
    DirectX, удивительное рядом...