1. Этот сайт использует файлы cookie. Продолжая пользоваться данным сайтом, Вы соглашаетесь на использование нами Ваших файлов cookie. Узнать больше.

Battlefield 2 не запускается

Тема в разделе "Компьютерные игры", создана пользователем Владимир П., 22.10.05.

  1. Владимир П.

    Владимир П. Активный участник

    1.715
    0
    Доброе время суток!

    У меня проблема: купил BattleField 2, установил, а он не запускается!
    Сначала требовал установки нового дирекса, типа нет файла d3d9_x25.dll или что-то в этом роде. Установил Дирекс, ошибки такой больше нет, но все равно не запускает, повисит-повисит и вылетает.
    Конфиг: P-1200 Mhz, Ram 512 Mb, GeForce 4 ti4200 128 Mb.
    Маленькая просьба: не надо только реплик типа - смени видюху, купи пейджер в Интерпейджинге, и всего такого..

    Давайте конструктивно. Всем спасибо, всем до-свидания.
     
  2. Вернер

    Вернер Активный участник

    6.687
    106
    Владимир П.
    Игра у вас и не пойдёт, так как требует видеокатрочку с pixel shader 2.0. GF4 4200ti к ним к сожалению не относится.
     
  3. Roman-web

    Roman-web Активный участник

    5.734
    0
    на самом деле проблема в видюхе.
    минимальную на которой видел, чтобы запускалась эта игруха нВидиа 5900

    у меня на форсе 6600 просто летает.
     
  4. Владимир П.

    Владимир П. Активный участник

    1.715
    0
    Может, в таком случае, кто-нибудь подскажет, есть ли способы эмуляции shader 2.0, или это все только пересуды. Я читал, существуют программы-эмуляции позволяющие запускать такие игры и чуть-ли на 2-ом ДжиФорсе, правда качество отстойное получается. Всем спасибо.
     
  5. Владимир П.

    Владимир П. Активный участник

    1.715
    0
    И кстати, ошибка возникает не в самом exe файле, а в прилагаемой библиотеке renddx9.dll, т.е. другими словами, если пофикисть приложение, каким-то патчем, это ровным счетом ничего не даст, так как будет запрос в библиотеку и она уже глюкнет.
     
  6. IvUs

    IvUs Активный участник

    10.987
    57
    Владимир П.

    Процессора твоего, похоже тоже не хватит:

    ========================================================================
    System Requirements
    ========================================================================

    - Operating System
    Windows XP (32 Bit Version)

    - CPU
    Battlefield 2 supports the following processors:
    Intel Pentium 4
    Intel Xeon
    Intel Pentium Extreme Edition
    Intel Celeron D
    AMD Athlon XP
    AMD Athlon 64
    AMD Athlon 64-FX
    AMD Sempron processor

    - Minimum Specification:
    CPU: 1.7 Ghz
    RAM: 512 Mb
    Video Card: NVidia GeForce FX 5700, ATI Radeon 8500 or ATI Radeon 9500
    with 128 Mb of RAM

    - Recommended Specification:
    CPU: 2.4 Ghz
    RAM: 1 Gb
    Video Card with at least 256 Mb of RAM

    - Video Cards
    Battlefield 2 only supports the following video cards:
    Radeon X700 (PCIe)
    Radeon X600 (PCIe)
    GeForce 6600 (PCIe)
    GeForce PCX 5900 (PCIe)
    GeForce 5800 Series (AGP)
    ATI Radeon X800 XT Platinum Edition
    ATI Radeon X800 PRO
    ATI Radeon 9800 Series
    ATI Radeon 9600 Series
    ATI Radeon 9550 (RV350LX)
    ATI Radeon 9500 / 9700 Series
    ATI Radeon 8500 Series
    ATI Radeon X300 Series
    NVidia GeForce 6800 Ultra
    NVidia GeForce 6800 GT
    NVidia GeForce 6800
    NVidia GeForce FX 5950 Series
    NVidia GeForce FX 5900 Series
    NVidia GeForce FX 5700 Series



    ========================================================================
     
  7. Ярик

    Ярик Активный участник

    4.173
    4
    Вернер
    С какого перпугу там обязательными стали ПС 2.0?
    Вон IvUs привел отрывок с требованиями (идут с самой игрой)
    ATI Radeon 8500 Series
    ATI Radeon X300 Series
    В жизни не были ПС 2.0 :) но заявленны как карты на которых игра идет..

    Владимир П.
    Пофиксеть можео 3дАналайзом..(прога будут передавать преложению что твоя видюха потдерживает ПС2.0 -или что выберешь)...
    Правда дело не в них Е:) :upset:
     
  8. PoliceMan

    PoliceMan Активный участник

    3.435
    0

    Это и естественно, эта библиотека отвечает за рендер 3D графики, используя API DX9, поэтому при обращении к ней(читай, при попытке инициализировать PS1.4) возникает ошибка.

    Вот отрывок из всех новостных порталов:
    Видеокарта GeForce 4 Ti4200 поддерживает шейдеры до 1.3 включительно, отсюда и проблемы.
    Скачать 3D-Analyze можно с официального сайта:
    http://www.tommti-systems.de/main-Dateien/files.html
    Должно помочь, только если там сильно завязано на PS то эффекта не будет, игра конечно запустится, но видно ничего не будет.
     
    Последнее редактирование: 23.10.05
  9. Вернер

    Вернер Активный участник

    6.687
    106
    Да, перепутал 1.4 с 2.0. Но суть остаётся с прежняя. Да, есть "патч" изготовленный одним умельцем, который позволяет запустить игру и на более старых видеокартах, однако качество, скажем, гмм, не очень. Да и поиграть на ранковых серверах вы не сможете, ибо punk buster этот патч "отвергнет".
    Да и P-1300 слабоват будет для игры.
     
  10. Владимир П.

    Владимир П. Активный участник

    1.715
    0
    Все, скачал я 3D-Analyze, спасибо PoliceMan. распаковал, запустил, установил галочки на игнорировать pixel shader 2.0 и ничего, все тоже самое, за исключением того, что в журнале событий, не отобразилось никакой информации.
    Раньше там возникала красная иконка и описание: мол, так там и так, ошибка в там-то там. А сейчас, как будто и ошибки не было.
    Правда там до фига всяких галочек, какие ставить?
     
  11. PoliceMan

    PoliceMan Активный участник

    3.435
    0
    Владимир П.
    Поиграйся с галочками эмуляции. Там они вынесены.
     
  12. Cher

    Cher Активный участник

    658
    0
    еще важно какая у тебя система, батлл официально идет только на XP. Сам когда пришел домой с первой в жизни лицензией и обломался, был мягко говоря раздосадованн, у меня стоит 2000-ная и игра висла после слов Welcome to ... Умельцы это легко решили, надо чуть в настройках карточки поквырятся, снизить там что-то, в нете лежит решение проблемы
     
  13. Владимир П.

    Владимир П. Активный участник

    1.715
    0
    Вообщем, ситуация на данный момент вырисовывается следующая: Я на каком-то, мать его, сайте вычитал, типа, у каких карт есть поддержка pixel shader 2.0. списко солдиный, там радеон 9600, там джифорсе 4600 и т.д. и.п. но самое главное в это списке присутствовала карта Radeon 9200 SE. Чему я обрадовался и быстро купил у моего знакомого такую карточку. К величайшему сожалению, BattleField 2.0 на ней не запустился опять. Тоже самое, такая же песня. renddx9.dll по адресу 00cb898. must die. Но вопрос у меня больше не почему не запускается баттлфиелд, а почему компания eagames выпускает игры ориентированные на какой-то определенный диапазон геймеров? и почему не пытается внедрить, простите "впарить", свою игру как можно большему количеству людей? Хотя на коробке есть очень хорошая надпись - "кто не ознакомился с требованиями к игре прежде чем ее купить и у кого игра после этого не пошла, то продавец может на вас на срать и не рассматривать ваши претензии. игра возврату не подлежит." - не цитата.
     
  14. Cher

    Cher Активный участник

    658
    0
    Владимир П. тебе так и сяк апгрейдится уже все-таки пора
     
  15. Вернер

    Вернер Активный участник

    6.687
    106


    Оо, сколько "ласковых слов", протестов в сторону EA было по этому поводу. Хотя естесственно, ничего это не дало.
     
  16. TokcbI4

    TokcbI4 Новичок

    64
    0
    Владимир П.
    Была та же мура с не запуском и отсутствием d3d9_x25.dll ,но на диске был патч вернее сей кодек vp6 vfw codec..скачай,поставь и вперед ;)
     
  17. Крюшон

    Крюшон Читатель

    236
    0
    Владимир П. Видяха у тебя не тянет эту игру просто.Да даже если бы потянула,она у тебя тормозила бы жестоко.Вообще Battlfield 2 не стоит того чтобы из-за неё заморачиваца и что то делать.Игра очень отстойная и тормазнутая.Графика ниче особенного,а требования великие.
     
  18. *AdaPtoR*

    *AdaPtoR* Активный участник

    3.088
    0
    Слушайте, а на Pentium M 1,6 ГГц (Dothan) с 32 Мб видео Intel 855 пойдет или нет? Памяти 512 Мб.
    Уже и так и сяк пробовал - не идет и все.
     
  19. PoliceMan

    PoliceMan Активный участник

    3.435
    0
    *AdaPtoR*
    Думаю, что слабоват ноут, для такой игры. Видяха особенно.
     
  20. Вернер

    Вернер Активный участник

    6.687
    106
    *AdaPtoR*
    Проц и память в порядке, а вот видяха слабовата будет (если вообще пойдёт из за шейдеров). У меня на схожем ноуте, но с АТИ9700 с 64-ю метрами нормально идёт.
     
  21. Крюшон

    Крюшон Читатель

    236
    0
    Для BF2 нужно минимум P4 2000 MHz,512 ram,видяха не ниже radeon 9600.
     
  22. Zuka58

    Zuka58 Активный участник

    2.299
    7
    GeForce 6600 AGP. Пойдет на ней?

    В списке её нет. Гугление дает разные результаты. У кого-то работает, у кого-то нет. Есть очевидцы, у которых запустилась?
     
  23. PoliceMan

    PoliceMan Активный участник

    3.435
    0
    Скорее всего пойдет.