1. Этот сайт использует файлы cookie. Продолжая пользоваться данным сайтом, Вы соглашаетесь на использование нами Ваших файлов cookie. Узнать больше.

SSL на FreeBSD 5.3

Тема в разделе "Софт", создана пользователем Klaus, 25.04.05.

  1. Klaus

    Klaus Новичок

    31
    0
    Доброго всем времени суток! :cool:
    Суть проблемы: есть сервер на котором крутится фря 5.3 и установлены usermin для юзверей и webmin для администрирования. При попытке направить траффик через SSL получается вот это (баг не в прокси - SSL он точно не режет):

    Сертификаты вроде в порядке. Если кто сталкивался с подобным - помогите, плиз...
     
  2. Spawn

    Spawn Активный участник

    903
    0
    к сожалению не сталкивался, но попробую по искать решение проблеммы
     
  3. Lord_Jadeite

    Lord_Jadeite Участник

    410
    0
    Файрвол не блокирует соединения на порт 20000? В squid.conf исходящие на 20000 порт разрешены?
     
  4. Bob

    Bob Активный

    21.804
    0
    Lord_Jadeite
    Похоже на то. Klaus попробуй телнетом туда подключиться, хоть будет видно, где проблема.
     
  5. Spawn

    Spawn Активный участник

    903
    0
    хм, если фаер, то по умолчанияю в 5.3 стоить разрешаюший режим allow from any to any.
     
  6. Klaus

    Klaus Новичок

    31
    0
    в том-то и дело, что файрвол настроен по дефолту, благо особой секурности в локалке пока не надо, squid ssl пропускает точно, проверил на нескольких сайтах, да и при коннекте на https://localhost:20000 напрямую тож error светится...
    к слову о телнете:

    [17:24][~]# telnet **** 20000
    Trying 192.168.231.2...
    Connected to *******.ru.
    Escape character is '^]'.
    close
    HTTP/1.0 302 Moved Temporarily
    Date: Tue, 26 Apr 2005 14:21:11 GMT
    Server: MiniServ/0.01
    Location: https://192.168.231.2:20000/
    Connection: close
    Connection closed by foreign host.

    что и непонятно - коннект то есть...
     
  7. Bob

    Bob Активный

    21.804
    0
    Klaus похоже тебя сервис (какой я так и не въехал) отфутболивает, там ищи.
     
  8. Klaus

    Klaus Новичок

    31
    0
    На счет сервиса - не уверен. Наружу светятся только ssh, proftpd, samba и ldap (без tls SASL и ssh), ну и bind с dhcpd соответственно, куда ж без них :)
    Из всего перечисленного пробовал вырубить всё - не помогло...
     
  9. Klaus

    Klaus Новичок

    31
    0
    Всем спасибо, проблема решена - баг исчез после обновления (make deinstall; make reinstall clean) openssl и перевода служб из inetd.conf в rc.conf:

    inetd_enable="NO"
    sshd_enable="YES"
    usbd_enable="YES"
    lisa_enable="YES"
    webmin_enable="YES"
    usermin_enable="YES"
    slapd_enable="YES"
    slapd_flags='-h "ldapi://%2fvar%2frun%2fopenldap%2fldapi/ ldap://0.0.0.0/"'
    slapd_sockets="/var/run/openldap/ldapi"
    proftpd_enable="YES"
    nmbd_enable="YES"
    smbd_enable="YES"
    winbindd_enable="YES"