1. Этот сайт использует файлы cookie. Продолжая пользоваться данным сайтом, Вы соглашаетесь на использование нами Ваших файлов cookie. Узнать больше.

sshd не стартует при запуске

Тема в разделе "Софт", создана пользователем Berman, 09.12.14.

  1. Berman

    Berman Читатель

    9.324
    0
    подымал на днях шлюз на линухах.
    все настроил локально, но для удаленного управления нужен ssh.
    установил, настроил, демона стартанул, в автозапуск прописал. перегружаюсь - нет его.
    service sshd status пишет dead
    стартанул вручную, все пошло. проверил автозагрузку - все стоит. перегрузился - опять та же шняга. в общем вбил костыль - прописал старт демона в стартовых скриптах. но осадочек остался. к тому же шлюз будет растиражирован под ВМ.

    дистр - OpenMandriva
    то ли Роса изгадила нормальный в принципе дистр, то ли еще чо не так.
    сижу в сомнениях, может Цент накатить и не выделываться?
    кто-нибудь с таким поведением SSH сталкивался?
     
  2. хочу_вот_сказать

    хочу_вот_сказать Активный участник

    8.402
    1
    а в логах чё?

    как можно вообще с чем-то кроме debian работать? извращенцы!

    ---------- Сообщение добавлено 09.12.2014 17:24 ----------

    скинь мне доступ чтоли в приват погляжу ради любопытства всё равно заняться нечем
    только и делаю что гажу на вфе целый день
     
  3. gerodoth

    gerodoth Активный участник

    8.184
    42
    +1
     
  4. Berman

    Berman Читатель

    9.324
    0
    как ваще можно работать с чем то кроме RHEL?
    давайте не будем устраивать холивары. у меня есть такой большой талмуд,
    [​IMG]
    в котором ни слова о дебиане нет, зато есть про openSUSE, Red Hat Enterprise Linux, Solaris, HP-UX.
    домашняя система всю дорогу была манрива. на работе цент и рхел


    а чо в них будет, если демон просто тупо не стартует?


    тебе по вебмину или ssh?
     
  5. хочу_вот_сказать

    хочу_вот_сказать Активный участник

    8.402
    1
    Berman, ну ты б ещё такое прикупил

    [​IMG]

    а как ты по ssh дашь если он у тебя не стартует? тимвью какой-нить...
    стартует не стартует, какая разница, в логах будут логи с причиной того почему не стартуют

    ты там случаем не обновлялся перед тем как всё умрело?

    ---------- Сообщение добавлено 09.12.2014 19:58 ----------

    у тебя это виртуальная машина или комп?
     
  6. icefrog

    icefrog Активный участник

    591
    0
    apt-get install openssh

    Если проблема не исчезнет:
     
  7. Berman

    Berman Читатель

    9.324
    0
    отты не сравнивай эти книжнки. кстати у ibm на дистанционной сертификации тоже никаких дебиванов.

    ну говорю ж. костыль вбил. теперь стартует. но неправильно это костылями лечить.
    в логах самого sshв ничего кроме того что я туда заходил, и какой то дебил рутом ломится. в других логах тоже ничего не нашел. оно просто не стертует, какбутто тупо игнорит то что ему сказали при запуске стартовать.

    комп + esxi + Lx


    апт-гет говоришь? а urpmi не хотел?
    если чо openssh по дефолту ставится в составе дистра но по дефолту же в автозагрузку не включена.
    я ее втуда прописал, но ничо не изменилось.
     
  8. хочу_вот_сказать

    хочу_вот_сказать Активный участник

    8.402
    1
    Berman, journalctl | grep ssh
    ssh -t
    ls -la /etc/ssh

    в студиё
    сразу после ребута

    ---------- Сообщение добавлено 09.12.2014 23:22 ----------

    esxi это правильно

    ---------- Сообщение добавлено 09.12.2014 23:30 ----------

    а так же
    cat /etc/sshd_config

    systemd у тебя?

    ---------- Сообщение добавлено 09.12.2014 23:33 ----------

    Berman, скинь ssh сам посмотрю
     
  9. icefrog

    icefrog Активный участник

    591
    0
    Berman, удали тогда Linux и поставь Windows не мучай ни себя ни других :d
    Ну, а если серьезно, можешь попробовать сменить 22 порт на любой другой и попробовать опять?)
     
  10. хочу_вот_сказать

    хочу_вот_сказать Активный участник

    8.402
    1
    как можно советы давать не видя логов :hah:
     
  11. Berman

    Berman Читатель

    9.324
    0
    да чо ты говоришь? я это до первого старта ssh сделал
    сострил тупым концом. а можешь ты мне рассказажешь как линукс подружить с континетом?
    я ж говорю не было в логах ничего о ssh. кроме моих входов. но это уже лог самого ssh.

    вопшем, проблему решил установив пакет от цента. самое интересное что конфиг тот же, ничо не менял. видать роса чото напортачила.
     
  12. хочу_вот_сказать

    хочу_вот_сказать Активный участник

    8.402
    1
    Berman, мб у тебя система проапгрейдился с инит скрипта на системд вот всё и умерло... вообще в таких случаях самое простое решение, как правило, полное удаление пакета и реинстал..

    ---------- Сообщение добавлено 10.12.2014 00:00 ----------

    и чё в journalctl тоже пусто было? )

    ---------- Сообщение добавлено 10.12.2014 00:01 ----------

    много дистров юзал, начинал ваще с альтлинуха, потом как рас мандрива была
    но эт начало нулевых
    ща у меня абсолютно всё на дебиане. чистый кайф.

    ---------- Сообщение добавлено 10.12.2014 00:02 ----------

    но ваще зря ты так всё сделал, неужели не было интересно почему не работало чота... а вдруг потом опять наткнёшься и так же костылями решать бушь
     
  13. RubiN

    RubiN Активный участник

    5.530
    31
    ночная сборка :shuffle:
     
  14. Berman

    Berman Читатель

    9.324
    0
    пусто. ручной запуск - нормально все
     
  15. хочу_вот_сказать

    хочу_вот_сказать Активный участник

    8.402
    1
    так ты обновлял ось? я как в иннетах почитал обычно слетает у всех когда с инитскриптов ось на системд переходит
     
  16. Berman

    Berman Читатель

    9.324
    0
    мандрива в начале нулевых была УГ. примерно с 2009 получилось чтото приятное. я долго сидел на 2010lar. вот решился попробовать чо там роса из мандривы сделала.
    такто у нас на шлюзах обычно openbsd ставят.

    ---------- Сообщение добавлено 10.12.2014 00:24 ----------

    дык нет еще. думал настрою все и потом. тока поставил. еще даже в мир ее не выпускал. видишь же в логах внутренний IP
     
  17. Berman

    Berman Читатель

    9.324
    0
    так оттого и тема родилась. а помогло наверное вот
    ну могу конешно поэкспериментировать и удалить пакет от цента и воткнуть родной. могу отписаться о результатах.
     
  18. хочу_вот_сказать

    хочу_вот_сказать Активный участник

    8.402
    1
    Berman, попробуй если не сложно
     
  19. pm

    pm Активный участник

    788
    0
    может сетевой интерфейс не успевает подыматься до запуска sshd при загрузке?
    помогут зависимости, хотя ХЗ как они в мандриве... могу только по убунте подсказать
     
  20. Redrik

    Redrik Активный участник

    14.021
    0
    Berman, забей Мандриву. Она немного сдохла.
    Вот более удачный ее же форк - http://ru.wikipedia.org/wiki/Mageia у него даже интерфейс, практически, один в один с мандривой.
    ИМХО в нем нет таких траблов.

    А в остальном, соглашусь с предыдущим оратором. Скорее всего нужно прописать зависимости или, на креняк, сделать отложенный старт службы sshd.

    Предыдущим ораторам хотелось бы сказать, что Red Hat весьма надежно показывает себя в качестве сетевого сервиса, в отличие от всяких дебианов и прочих убунтов, которые как ни крути, достаточно глючны.
    По этой причине Red Hat пользуется доброй славой.
    Не фряха, конечно, но имеет свои плюсы.
    За 4 года у меня этот сервер, на самой мусорной машине не сбойнул вообще ни одного раза будучи загруженным под завязку.
    Как поставил 4 года назад, так больше к нему не подходил.

    При всей моей симпатии к Убунте, вся линейка дебианов, ИМХО, соревнуется сама с собой когда же по глючности догонит Windouze.