1. Этот сайт использует файлы cookie. Продолжая пользоваться данным сайтом, Вы соглашаетесь на использование нами Ваших файлов cookie. Узнать больше.

Joomla не загружает zip

Тема в разделе "Программирование", создана пользователем Devillio, 13.03.12.

  1. Devillio

    Devillio Активный участник

    1.192
    0
    Добрый день.
    Помогите ламеру с настройкой :shuffle:

    Проблема такая. Закинул на сайт Joomla, установилась без проблем.
    Однако, не могу установить ни шаблон, ни языковой пакет. Судя по всему, что-то с правами, не могу понять что.
    Ошибка при загрузке zip такая:
    [​IMG]
    Права на все директории установлены как 775 (хотя достаточно должно быть 755).

    Поиск проблемы позволил определить, что: файл zip (с шаблоном или языком) на сайт закачивается, в папку /tmp. Затем создается там же временная папка /tmp/install_xxxxxxxx. А вот распаковка в эту папку не проходит... Код в php, где не проходит:

    (то есть при записи файла в файловой системе)

    В папке tmp на этот момент все выглядит так:
    [​IMG]
    (попутный вопрос - что такое 10011 и 80?)

    Дальнейший разбор полета привел сюда:
    [​IMG]
    т.е. Safe Mode = On
    Провайдер говорит, что отключить нельзя.
    Т.е. дальше я проверять не знаю что, в чем проблема? :shuffle:

    p.s. При попытке установки из папки, пишет
    "Install path does not exist
    Package Install: There was an error installing an extension: site_ru-RU.zip"
    (естесно, language присутствует, права там 775. Я так понимаю, в language не может создать ru-RU)
     
  2. muhon

    muhon Активный участник

    1.373
    3
    Joomla Помощь > Информация о системе > Права на папки проверяем доступность записи
    если все ок, то надо забороть safemode
    как-то так

    .htaccess file with 'php_flag' like this:

    php_flag register_globals off

    ну если хостер и этого не позволяет,
    тогда
    1. Просим хостера safe mode в off
    2. Если не дают, то просим safe_mode_gid
    3. Если 1 и 2 не получилось, меняем хостера на нормального.
     
  3. sergogogo

    sergogogo Активный участник

    3.144
    0
    сразу меняйте прова! их таких мало уже осталось, выбор огромен щас! шо вы в игрушки играетесь?!!))
    шаблон не встал - только ягодки, установка шаблона - это элементарная распаковка файлов в соответствующее место, ппц! а когда компонент надо будет устанавливать, когда в базу надо будет что-нить писать? шо за пров-то? такой шнягой раньше зенон баловался....

    ---------- Сообщение добавлено 13.03.2012 13:38 ----------

    это мы проходили!)))) потом опля! - пров скажет - какой-то там сайт не соблюдает политику безопасности, прищлось для защиты остальных сайтов все вернуть ВЗАД!))) и все....
     
  4. Devillio

    Devillio Активный участник

    1.192
    0
    Итак, провайдер пообещал "запилить под нас новый хостинг без сэйф-мода" (с). 1-2 дня :)
    Мы довольны, приятно. Посмотрим, в этом ли причина...

    Подскажите, что значат 10011 и 80 на второй картинке?
     
  5. muhon

    muhon Активный участник

    1.373
    3
    пара строк в .htaccess или в конфиге виртуального хоста со стороны прова:)

    ---------- Сообщение добавлено 13.03.2012 16:53 ----------

    помоему порты
     
  6. OpenBoy

    OpenBoy Активный участник

    21.665
    0
    первая колонка с цифирью - количество имен у обьекта ФС, вторая (80 и 10011) UID (по идее логичнее было бы там увидеть имя пользователя но так как операции с пользователями у хостера организованы скорее всего через LDAP или что-то навроде, то может их и не будет видно). Можно попробовать подкинуть команду cat /etc/passwd и посмотреть есть ли соответствия UID и имени в этом файле.
     
  7. The Last Winged

    The Last Winged Активный участник

    11.841
    54
    Можно и нужно. Он либо врет, либо некомпетентен.
    Зачем вам тупой либо врущий хостер?

    Не нужно на все. Нужно на определенные.
    Причем последняя цифра должна быть 6 или 7, т.к. пользователь и вебсервер могут быть в разных группах.
     
  8. Devillio

    Devillio Активный участник

    1.192
    0
    Дело было в SAFE MODE=OFF. Провайдер и правда "запилил", все поехало-завертелось.