1. Этот сайт использует файлы cookie. Продолжая пользоваться данным сайтом, Вы соглашаетесь на использование нами Ваших файлов cookie. Узнать больше.

Функции ссылки и поиска в Excell. Помогите!

Тема в разделе "Софт", создана пользователем Out Of My Mind, 01.10.08.

  1. Out Of My Mind

    Out Of My Mind Активный участник

    564
    0
    Прошу помощи в решении следующей задачи.
    есть база данных, которая выглядит примерно так, как показано на рисунке (файл 1233.jpg).
    мне необходимо автоматически переносить (подгружать по мере необходимости) данные в другой файл (пример - файл 1234.jpg).

    Сама ломала голову, вот до чего дошла:
    использую вместе функции ВПР, ИНДЕКС, ПОИСПОЗ следующим образом:
    основная функция - ВПР, которая ищет показатели продаж, в ее теле для обозначения границ массива поиска используются остальные функции.
    Например, чтобы найти сколько яблок продал Иванов, пишу в ячейке В3 книги 1234.xls следующую формулу:

    =ВПР("1";(ИНДЕКС('[1233.xls]Лист1'!$A$3:$B$20;ПОИСКПОЗ("Иванов";'[1233.xls]Лист1'!$A$3:$A$20;0);2)):(ИНДЕКС('[1233.xls]Лист1'!$A$3:$С$20;ПОИСКПОЗ("Петров";'[1233.xls]Лист1'!$A$3:$A$20;0);3));2;ЛОЖЬ)

    Однако, какие-то странности происходят: когда файл с базой данных открыт, все подгружается нормально, как только его закрываю, значения преобразоввываются в ненайденную ссылку, и выглядит это так: #ССЫЛКА!

    Может есть какой другой способ? в чем проблема здесь?
     

    Вложения:

    • 1233.JPG
      1233.JPG
      Размер файла:
      19,6 КБ
      Просмотров:
      49
    • 1234.JPG
      1234.JPG
      Размер файла:
      11,6 КБ
      Просмотров:
      59
  2. panda-34

    panda-34 Активный участник

    1.589
    0
    Проще нормализовать первую таблицу и свернуть ее в сводную таблицу. Без всяких извращений.
     
  3. Out Of My Mind

    Out Of My Mind Активный участник

    564
    0
    panda-34,
    ну это я утрированно маленькую сделала и про груши-))
    на самом деле это выгрузка из опреационной базы по одному подразделению, количество строк в которой не менее 500.
    таких подразделений более 40.
    выгрузки делаются с довольно частой периодичностью.
    трудно все руками в удобочитаемый вид приводить, вот и приходится извращаться :)
     
  4. panda-34

    panda-34 Активный участник

    1.589
    0
    Ну так переделать выгрузку чтобы фамилия была в колонке (если это 1с, нужно два клика мыши на это). Либо сделать нормализацию прямо в Excelе. Для приведенного примера это сделает функция (в столбце) =ЕСЛИ(КодСтроки=0;ВидПродукта;R[-1]C)